const regex = /\d\d\d\.\d\d\d\.\d\d\d-\d\d|\d\d\.\d\d\d\.\d\d\d\/\d\d\d\d-\d\d(?=\|\d\d\.\d\d\d\.\d\d\d\/\d\d\d\d-\d\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d\\d\\d\\.\\d\\d\\d\\.\\d\\d\\d-\\d\\d|\\d\\d\\.\\d\\d\\d\\.\\d\\d\\d\\\/\\d\\d\\d\\d-\\d\\d(?=\\|\\d\\d\\.\\d\\d\\d\\.\\d\\d\\d\\\/\\d\\d\\d\\d-\\d\\d)', 'gm')
const str = `MARKET S.A.|41.355.058/0001-35| |123,45
MARKET S.A.|41.355.058/0001-35|681.538.156-01|123,45
MARKET S.A.|41.355.058/0001-35|70.092.275/0001-88|123,45`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}