re = /(?<=[\w ]{5})\w+/m
str = 'I am a phrase and everything is matched after 10 characters.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end