#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(?:[_a-z0-9](?:[_a-z0-9-]{0,61}[a-z0-9])?\.)+(?:[a-z](?:[a-z0-9-]{0,61}[a-z0-9])?)?$"
Local $sString = "This regexp can be used to validate domain names in Golang. While it cannot enforce the 253 character limit (with optional trailing period not included) that can be easily done by a simple len(domain) <= 253 check as well." & @CRLF & _
"" & @CRLF & _
"This can be used as-is in other languages, even with RE2 regex engine. If positive lookbehind assertions are available, the character limit can be used. " & @CRLF & _
"" & @CRLF & _
"Non-capturing groups are used." & @CRLF & _
"" & @CRLF & _
"Example validated domains (some may be invalid per TLD rules):" & @CRLF & _
"" & @CRLF & _
"example.com" & @CRLF & _
"_25._tcp.SRV.example" & @CRLF & _
"punycoded-idna.xn--zckzah" & @CRLF & _
"under_score.example" & @CRLF & _
"" & @CRLF & _
"Example invalid domains:" & @CRLF & _
"" & @CRLF & _
"192.0.2.1" & @CRLF & _
"has spaces.com" & @CRLF & _
"easy,typo.example" & @CRLF & _
"domain\.escapes.invalid" & @CRLF & _
"no_trailing_.invalid" & @CRLF & _
"-leading-or-trailing-.hyphens.invalid" & @CRLF & _
"" & @CRLF & _
"TLDs have more validation, the following will not validate:" & @CRLF & _
"" & @CRLF & _
"example" & @CRLF & _
"digit.1example" & @CRLF & _
"underscore._example_com" & @CRLF & _
"" & @CRLF & _
"but with a trailing period, the same rules as non-TLD are applied:" & @CRLF & _
"" & @CRLF & _
"example." & @CRLF & _
"192.0.2.1." & @CRLF & _
"digit.1example." & @CRLF & _
"underscore._example_com." & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")