import re
regex = re.compile(r"^(?:[_a-z0-9](?:[_a-z0-9-]{0,61}[a-z0-9])?\.)+(?:[a-z](?:[a-z0-9-]{0,61}[a-z0-9])?)?$", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("This regexp can be used to validate domain names in Golang. While it cannot enforce the 253 character limit (with optional trailing period not included) that can be easily done by a simple len(domain) <= 253 check as well.\n\n"
"This can be used as-is in other languages, even with RE2 regex engine. If positive lookbehind assertions are available, the character limit can be used. \n\n"
"Non-capturing groups are used.\n\n"
"Example validated domains (some may be invalid per TLD rules):\n\n"
"example.com\n"
"_25._tcp.SRV.example\n"
"punycoded-idna.xn--zckzah\n"
"under_score.example\n\n"
"Example invalid domains:\n\n"
"192.0.2.1\n"
"has spaces.com\n"
"easy,typo.example\n"
"domain\\.escapes.invalid\n"
"no_trailing_.invalid\n"
"-leading-or-trailing-.hyphens.invalid\n\n"
"TLDs have more validation, the following will not validate:\n\n"
"example\n"
"digit.1example\n"
"underscore._example_com\n\n"
"but with a trailing period, the same rules as non-TLD are applied:\n\n"
"example.\n"
"192.0.2.1.\n"
"digit.1example.\n"
"underscore._example_com.\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")