$re = '/[-,\.\s]/m';
$str = 'Maynard Victor P. Ausburn';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;