$re = '/(?<=identifier{ ).*?(?<!})(?= *}(?!}))/m';
$str = 'identifier{ {{var1}} rest of the content} outer content identifier{ {{var2}} another content} identifier{ content with no vars }';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);