re = /(?<=identifier{ ).*?(?<!})(?= *}(?!}))/m
str = 'identifier{ {{var1}} rest of the content} outer content identifier{ {{var2}} another content} identifier{ content with no vars }'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end