package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9]+[A-Z]?(-[0-9])?$`)
var str = `1234567-8
1234567
1234567A-8`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}