$re = '/^[0-9]+[A-Z]?(-[0-9])?$/m';
$str = '1234567-8
1234567
1234567A-8';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);