using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<MC>mc16[acde])\.(?P<SHORTNAME>.+?)\.(?P<MXAODFLAVOUR>MxAOD.+?)\.(e[0-9]+_s[0-9]+_r[0-9]+)?_?(?P<PTAG>p[0-9]+)(?:\.(?P<HTAG>h[0-9]+(?:-\w+?)?))?(?:(?:\.|_)(?P<N>[0-9]+))?\.root";
string input = @"mc16a.MGPy8_tHjb125_yt_plus1.MxAODDetailed.e4606_s3126_r9364_p3665.root
mc16a.PowhegPy8_NNPDF30_VBFH125.MxAODDetailed.e5720_s3126_r9364_p3665.root
mc16a.PowhegPy8_NNLOPS_ggH125.MxAODDetailed.e5607_s3126_r9364_p3665.root
mc16a.PowhegPy8_NNLOPS_ggH125.MxAODDetailed.e5607_s3126_r9364_p3665.h024.root
mc16d.PowhegH7_NNLOPS_ggH125.MxAODDetailed.p3524.h021-pid.root
mc16a.MGPy8_ttgamma_nonallhadronic_AF2.MxAODDetailed.p3469.h019.root
mc16a.PowhegPy8_NNPDF30_VBFH125.MxAODLeptonMETSys.p3404.h019.004.root";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}