package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\x00-\x7F]`)
var str = `a b A B C D E F
â ä è ê Ç ½ à è`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}