$re = '`[^\x00-\x7F]`m';
$str = 'a b A B C D E F
â ä è ê Ç ½ à è';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);