using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\s|^)'(?=\w)|(?<=\w)'(?=\s|$)";
string input = @"'tis the season
Qur'an
And 'tis the season to be jolly.
The shoe was Curtis'";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}