$re = '/(?<=\s|^)\'(?=\w)|(?<=\w)\'(?=\s|$)/m';
$str = '\'tis the season
Qur\'an
And \'tis the season to be jolly.
The shoe was Curtis\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);