const regex = /\b[a-z]*?(?:(?=c1)|\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[a-z]*?(?:(?=c1)|\\d)', 'gm')
const str = `aa aab1 aa
aa aac1 aa
aa aac2 aa`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}