$re = '/\b[a-z]*?(?:(?=c1)|\d)/m';
$str = 'aa aab1 aa
aa aac1 aa
aa aac2 aa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);