using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[a-zA-Z])[@31!]+(?=[a-zA-Z])";
string input = @"@@He11o Wor1d!
!!T3ach !m3
@13!
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}