$re = '/(?<=[a-zA-Z])[@31!]+(?=[a-zA-Z])/';
$str = '@@He11o Wor1d!
!!T3ach !m3
@13!
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);