using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{3}";
string substitution = @" $0";
string input = @"11222333";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}