package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*(\{[^{}]*})[^/]*$`)
var str = `abc {popo}/popo/{ahhh}
abc {popo}/popo/{ahhh}test
abc {popo}/popo/{ahhh}{1}test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}