// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*(\{[^{}]*})[^/]*$").unwrap();
let string = "abc {popo}/popo/{ahhh}
abc {popo}/popo/{ahhh}test
abc {popo}/popo/{ahhh}{1}test";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}