package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*)\r?\n(.*)\r?\n(.*)(?:\r?\n|$)`)
var str = `1000
AAAAAAAAAA
100,000.00
2000
BBBBBBBBBB
200,000.00
3000
CCCCCCCCCC
300,000.00
4000
DDDDDDDDDD
400,000.00`
var substitution = "$1|$2|$3\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}