re = /(.*)\r?\n(.*)\r?\n(.*)(?:\r?\n|$)/m
str = '1000
AAAAAAAAAA
100,000.00
2000
BBBBBBBBBB
200,000.00
3000
CCCCCCCCCC
300,000.00
4000
DDDDDDDDDD
400,000.00'
subst = '$1|$2|$3\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result