#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?!\.)[\w-_.]*[^.])(@\w+)(\.\w+(\.\w+)?[^.\W])$"
Local $sString = "lama.loca.loca123@inca.com" & @CRLF & _
"" & @CRLF & _
"pio_pio@factory.com" & @CRLF & _
"" & @CRLF & _
"carnival666@hellmail.com" & @CRLF & _
"" & @CRLF & _
"la-lalai@gmail.com" & @CRLF & _
"" & @CRLF & _
"//INVALID EMAILS" & @CRLF & _
"//spaces at start" & @CRLF & _
" testmail@mail.com" & @CRLF & _
"" & @CRLF & _
"//start with points" & @CRLF & _
".testmail@mail.com" & @CRLF & _
"" & @CRLF & _
"//finish with points" & @CRLF & _
"testmail@mail.com." & @CRLF & _
"" & @CRLF & _
"//spaces into the string" & @CRLF & _
"testm ail@mail.com" & @CRLF & _
"" & @CRLF & _
"//Start/finish with any not number|letter char" & @CRLF & _
"" & @CRLF & _
"testmail@mail.com.de" & @CRLF & _
"testmail@mail.de.org"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")