import re
regex = re.compile(r"^((?!\.)[\w\-_.]*[^.])(@\w+)(\.\w+(\.\w+)?[^.\W])$", flags=re.MULTILINE)
test_str = ("lama.loca.loca123@inca.com\n\n"
"pio_pio@factory.com\n\n"
"carnival666@hellmail.com\n\n"
"la-lalai@gmail.com\n\n"
"//INVALID EMAILS\n"
"//spaces at start\n"
" testmail@mail.com\n\n"
"//start with points\n"
".testmail@mail.com\n\n"
"//finish with points\n"
"testmail@mail.com.\n\n"
"//spaces into the string\n"
"testm ail@mail.com\n\n"
"//Start/finish with any not number|letter char\n\n"
"testmail@mail.com.de\n"
"testmail@mail.de.org")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")