using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(emp\[\d+]\.)id=(\d+)&\1name=([^&]+)";
string input = @"http://localhost:8080/list?emp[0].id=21&emp[0].name=john&emp[1].id=22&emp[1].name=tom";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}