const regex = /(emp\[\d+]\.)id=(\d+)&\1name=([^&]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(emp\\[\\d+]\\.)id=(\\d+)&\\1name=([^&]+)', 'gm')
const str = `http://localhost:8080/list?emp[0].id=21&emp[0].name=john&emp[1].id=22&emp[1].name=tom`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}