$re = '/^(([0-9\s]+)?)+[a-zA-Z]*((\s?)*[a-zA-Z](\s?)*)(([0-9\s]+)?)*$/';
$str = '22ddfdsfsdfsfsf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);