re = /^(([0-9\s]+)?)+[a-zA-Z]*((\s?)*[a-zA-Z](\s?)*)(([0-9\s]+)?)*$/
str = '22ddfdsfsdfsfsf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end