package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)(^\d+)(\ )([A-Za-z])(.*)$`)
var str = `44 North Road #12
44 North Road #123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}