$re = '/(^\d+)(\ )([A-Za-z])(.*)$/im';
$str = '44 North Road #12
44 North Road #123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);