using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\/)(\/(?=\b).+)\[(\d+), (\d+)\]";
string substitution = @"$1:$2";
string input = @"// test /Users/zachhardesty/MEGA/ibm/webui/WEB_UI_CONTENT_REACT/src/modules/IdentitySources/Components/index.ts[1, 1]";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}