re = /(?<!\/)(\/(?=\b).+)\[(\d+), (\d+)\]/m
str = '// test /Users/zachhardesty/MEGA/ibm/webui/WEB_UI_CONTENT_REACT/src/modules/IdentitySources/Components/index.ts[1, 1]'
subst = '$1:$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result