$re = '/(?:([0-9]+)mm)(?: *x *([0-9]+)mm)?(?: *(\(Ø\)|\(WxH\)))?/';
$str = '335mm x 335mm (WxH) OR 335mm (Ø)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);