re = /(?:([0-9]+)mm)(?: *x *([0-9]+)mm)?(?: *(\(Ø\)|\(WxH\)))?/
str = '335mm x 335mm (WxH) OR 335mm (Ø)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end