package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((\()(?1)?(\))(?1)?)$`)
var str = `//SHOULD
()
(())
((()))
()()
(())()
()()()
()()()()()
(((())))
()((()))
()()()()((()))(())((()))(((((((())))))))
//NOT
(
)
)(
))((
)()(
(()
))
())
(()
()()())
()())
)))))))))
((((((((
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}