package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d+\D`)
var str = `1a,1b,2a, ... , 29c`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}