$re = '/\d+\D/';
$str = '1a,1b,2a, ... , 29c';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);