package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:^|,)(Word)(?:,|$)`)
var str = `Word,Word with Another,Word,ConcatWord,Word`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}