$re = '/(?:^|,)(Word)(?:,|$)/m';
$str = 'Word,Word with Another,Word,ConcatWord,Word';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);