#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?x) # invoke extended (aka free-spacing) mode" & @CRLF & _
"^ # match beginning of the string" & @CRLF & _
"[^"\n]* # match zero or more chars other than line terminators and double-quotes" & @CRLF & _
"" # match a double-quote" & @CRLF & _
"[^"\n]* # match zero or more chars other than line terminators and double-quotes" & @CRLF & _
"(?<! # begin a negative lookbehind" & @CRLF & _
" \ # match a space" & @CRLF & _
" | # or" & @CRLF & _
" \\n # match a backslash followed by n" & @CRLF & _
") # end negative lookbehind" & @CRLF & _
"" # match a double-quote" & @CRLF & _
"\n # match a newline" & @CRLF & _
"\ * # match zero or more spaces" & @CRLF & _
"" # match double-quote" & @CRLF & _
"[^ "\n] # match a character other than a space, double-quote or newline" & @CRLF & _
"[^"\n]* # match zero or more chars other than line terminators and double-quotes" & @CRLF & _
"" # match a double-quote" & @CRLF & _
"\n? # optionally match a newline" & @CRLF & _
"$ # match end of string"
Local $sString = "a c"d1 %"" & @CRLF & _
" "&g i"" & @CRLF & _
"" & @CRLF & _
""9"" & @CRLF & _
""&"" & @CRLF & _
"" & @CRLF & _
"d a"fe "" & @CRLF & _
" "3h j"" & @CRLF & _
"" & @CRLF & _
"a c"d1 \n"" & @CRLF & _
" "&g i"" & @CRLF & _
"" & @CRLF & _
"a"de f%x"" & @CRLF & _
" " &12 "" & @CRLF & _
"" & @CRLF & _
"#3 does not match due to space preceding second double-quote" & @CRLF & _
"#4 does not match due to a backslash followed by n preceding second double-quote" & @CRLF & _
"#5 does not match due to backslash followed by n following third double-quote" & @CRLF & _
"#5 does not match due to space following third double-quote" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")