// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?x) # invoke extended (aka free-spacing) mode
^ # match beginning of the string
[^"\n]* # match zero or more chars other than line terminators and double-quotes
" # match a double-quote
[^"\n]* # match zero or more chars other than line terminators and double-quotes
(?<! # begin a negative lookbehind
\ # match a space
| # or
\\n # match a backslash followed by n
) # end negative lookbehind
" # match a double-quote
\n # match a newline
\ * # match zero or more spaces
" # match double-quote
[^ "\n] # match a character other than a space, double-quote or newline
[^"\n]* # match zero or more chars other than line terminators and double-quotes
" # match a double-quote
\n? # optionally match a newline
$ # match end of string"#).unwrap();
let string = "a c\"d1 %\"
\"&g i\"
\"9\"
\"&\"
d a\"fe \"
\"3h j\"
a c\"d1 \\n\"
\"&g i\"
a\"de f%x\"
\" &12 \"
#3 does not match due to space preceding second double-quote
#4 does not match due to a backslash followed by n preceding second double-quote
#5 does not match due to backslash followed by n following third double-quote
#5 does not match due to space following third double-quote
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}