package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*([1-9][2-9]\d)$`)
var str = `-222`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}