$re = '/[A-Za-z\'/\\\\%]+(?![^{]*})(?![^\[]*\])(?![^<]*>)/m';
$str = '[beginning]<start>How\'s {the} /weather (\\\\today%?)[end]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);