re = /[A-Za-z'\/\\%]+(?![^{]*})(?![^\[]*\])(?![^<]*>)/m
str = '[beginning]<start>How\'s {the} /weather (\\\\today%?)[end]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end