package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d{4}-)(\d{2}-)(\d{2})`)
var str = `2022-08-21
2023-05-01, 2023-06-01`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}