$re = '/^(\d{4}-)(\d{2}-)(\d{2})/m';
$str = '2022-08-21
2023-05-01, 2023-06-01';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);