import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:<TD CLASS=\"label\")(?:.*>)(?s)(?<lbl>.*?)(?:<\\/TD>).*?(?:<TD NOWRAP>).*?(?:type=)\"(?<type>[^\"]*)\".*?(?:name=)\"(?<name>[^\"]*)\".(?:title=)\"(?<title>[^\"]*)\".*?(?:id=)\"(?<id>[^\"]*)\".*?(?:value=)\"(?<value>[^\"]*)\".*?(?:size=)\"(?<size>[^\"]*)\".*?(?:maxlength=)\"(?<maxlength>[^\"]*)\"*.*?<\\/TD>$";
final String string = "<tr>\n"
+ "<TD CLASS=\"label\" NOWRAP VALIGN=\"MIDDLE\">\n"
+ " Average_No_of_Direct_Employees:\n"
+ " \n"
+ "</TD>\n"
+ "<TD NOWRAP>\n"
+ "<INPUT CLASS=\"valueEditable\" TYPE=\"text\" NAME=\"_1_1_10_1\" TITLE=\"Average_No_of_Direct_Employees\" ID=\"_1_1_10_1\" VALUE=\"[LL_FormTag_1_1_10_1 /]\" SIZE=\"20\" MAXLENGTH=\"20\" ONCHANGE=\"markDirty();\">\n"
+ "</TD>\n"
+ "</TR>\n\n\n\n"
+ "<!-- End File: datefield.html (End - _1_1_9_1) -->\n"
+ "</TD>\n"
+ "</TR>\n"
+ "<TR CLASS=\"horizontalCellDivider\" >\n"
+ "<TD CLASS=\"labelHorizontalDivider\" COLSPAN=\"1\"><IMG HEIGHT=\"1\" ALT=\"\" SRC=\"/img/spacer.gif\" WIDTH=\"1\" BORDER=\"0\"></TD>\n"
+ "<TD CLASS=\"valueHorizontalDivider\" COLSPAN=\"1\"><IMG HEIGHT=\"1\" ALT=\"\" SRC=\"/img/tbl-divider-hor.gif\" WIDTH=\"3\" BORDER=\"0\"></TD>\n"
+ "</TR>\n"
+ "<TR>\n"
+ "<TD CLASS=\"label\" NOWRAP VALIGN=\"MIDDLE\">\n"
+ " Average_No_of_Direct_Employees:\n"
+ " \n"
+ "</TD>\n"
+ "<TD NOWRAP>\n"
+ "<INPUT CLASS=\"valueEditable\" TYPE=\"text\" NAME=\"_1_1_10_1\" TITLE=\"Average_No_of_Direct_Employees\" ID=\"_1_1_10_1\" VALUE=\"[LL_FormTag_1_1_10_1 /]\" SIZE=\"20\" MAXLENGTH=\"20\" ONCHANGE=\"markDirty();\">\n"
+ "</TD>\n"
+ "</TR>\n"
+ "<TR CLASS=\"horizontalCellDivider\" >\n"
+ "<TD CLASS=\"labelHorizontalDivider\" COLSPAN=\"1\"><IMG HEIGHT=\"1\" ALT=\"\" SRC=\"/img/spacer.gif\" WIDTH=\"1\" BORDER=\"0\"></TD>\n"
+ "<TD CLASS=\"valueHorizontalDivider\" COLSPAN=\"1\"><IMG HEIGHT=\"1\" ALT=\"\" SRC=\"/img/tbl-divider-hor.gif\" WIDTH=\"3\" BORDER=\"0\"></TD>\n"
+ "</TR>\n"
+ "<TR>\n"
+ "<TD CLASS=\"label\" NOWRAP VALIGN=\"MIDDLE\">\n"
+ " Average_No_of_SubContractors_on-site:\n"
+ " \n"
+ "</TD>\n"
+ "<TD NOWRAP>\n"
+ "<INPUT CLASS=\"valueEditable\" TYPE=\"text\" NAME=\"_1_1_11_1\" TITLE=\"Average_No_of_SubContractors_on-site\" ID=\"_1_1_11_1\" VALUE=\"[LL_FormTag_1_1_11_1 /]\" SIZE=\"20\" MAXLENGTH=\"20\" ONCHANGE=\"markDirty();\">\n"
+ "</TD>\n"
+ "</TR>\n"
+ "<TR CLASS=\"horizontalCellDivider\" >\n"
+ "<TD CLASS=\"labelHorizontalDivider\" COLSPAN=\"1\"><IMG HEIGHT=\"1\" ALT=\"\" SRC=\"/img/spacer.gif\" WIDTH=\"1\" BORDER=\"0\"></TD>\n"
+ "<TD CLASS=\"valueHorizontalDivider\" COLSPAN=\"1\"><IMG HEIGHT=\"1\" ALT=\"\" SRC=\"/img/tbl-divider-hor.gif\" WIDTH=\"3\" BORDER=\"0\"></TD>\n"
+ "</TR>\n"
+ "<TR>";
final String subst = "<div class=\"medium-6 columns\">\\n <label>${lbl} <!--### INPUT EXAMPLE ### -->\\n <input type=\"${type} <\" NAME=\"${name}\" TITLE=\"${title}\" ID=\"${id}\" VALUE=\"${value}\" SIZE=\"${size}\" MAXLENGTH=\"${maxlength}\" ONCHANGE=\"markDirty();>\\n </label>\\n</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}