const regex = new RegExp('^(BEGIN:)(4RF\\sProduct\\sInfo)(Version:)(?P<ver>\\d{1,3}.\\d{1,3})(Serial\\sNumber:)(?P<radio_serial>R\\d{10})(Part\\sNumber:)(?P<part_number>\\w{4}-M\\d{3}-N\\d{2}-P\\d-V\\d-\\w\\dA\\d)(LTE\\sModule\\sSerial\\sNumber:)(?P<lte_serial>\\w{6,20})(IMEI\\sNumber:)(?P<imei>\\d{14,15})(END:)(4RF\\sProduct\\sInfo)$', 'im')
const str = `BEGIN:4RF Product InfoVersion:1.0Serial Number:R6510000268Part Number:APLT-M001-N01-P0-V0-T0A1LTE Module Serial Number:UF006276700310IMEI Number:353533100762973END:4RF Product Info
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}