# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^(BEGIN:)(4RF\sProduct\sInfo)(Version:)(?P<ver>\d{1,3}.\d{1,3})(Serial\sNumber:)(?P<radio_serial>R\d{10})(Part\sNumber:)(?P<part_number>\w{4}-M\d{3}-N\d{2}-P\d-V\d-\w\dA\d)(LTE\sModule\sSerial\sNumber:)(?P<lte_serial>\w{6,20})(IMEI\sNumber:)(?P<imei>\d{14,15})(END:)(4RF\sProduct\sInfo)$
"""
test_str = ("BEGIN:4RF Product InfoVersion:1.0Serial Number:R6510000268Part Number:APLT-M001-N01-P0-V0-T0A1LTE Module Serial Number:UF006276700310IMEI Number:353533100762973END:4RF Product Info\n\n")
matches = re.search(regex, test_str, re.IGNORECASE | re.VERBOSE | re.MULTILINE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.